Download Lab:

button gns

 

Image requirements:
 Cisco IOSv        (vios-adventerprisek9-m.vmdk.SPA.156-2.T)


Introduction:
This Lab provides CCNA students to practice their BGP skills learned in the CCNA curriculums, topology has three autonomous systems, you will configure external BGP between two service providers and enterprise customer after BGP neighborships have been established you will advertise all necessary prefixes in the topology, additionally, you have to configure the EIGRP routing protocol to run within enterprise AS.

 

Topology:

img2 clipped rev 1

Lab tasks:

1. Configure EIGRP 10 within AS33, use precise network statements, only interface G0/2 on the ER1 has to participate in the routing process.

2. Verify that ER1's routing table contains all three /24 subnets of the router R2. (show ip route eigrp).

3. Configure eBGP neighborship between AS33 and AS11, use IP addresses of the link between ER1 and ISP1 to establish an eBGP session.

4. Verify that the external BGP session has been established between routers ER1 and ISP1. (show ip bgp summary, show tcp brief).

5. Configure eBGP neighborship between AS33 and AS22, use IP addresses of the link between ER1 and ISP2 to establish an eBGP session.

6. Verify that the external BGP session has been established between routers ER1 and ISP2. (show ip bgp summary, show tcp brief). At this point, AS33 edge router has to have two neighborships to its upstream peers.

7. Configure eBGP neighborship between AS11 and AS22, use IP addresses of the link between ISP1 and ISP2 to establish an eBGP session.

8. Verify that the external BGP session has been established between routers ISP1 and ISP2. (show ip bgp summary, show tcp brief).

9. Now that all BGP routers in the topology have been connected, its time to share routing information between autonomous systems. Starting with ER1, advertise AS33's subnets to ISP1 and ISP2 using network statements in the router BGP configuration mode, you have to create three individual statements for each of the router R2's subnet.

10. Verify that the router ER1 has placed EIGRP routes from the routing table to its BGP table. (show ip bgp).

11. Verify that AS33's prefixes have been propagated to AS11 and AS22. (show ip bgp).

12. Advertise AS11's prefixes to its peers in the AS22 and AS33. AS11's prefixes are subnets of Loopback 0 interface of the router ISP1. Use the network statement for each individual subnet.

13. Verify that the router ISP1 has placed its connected routes into its BGP table. (show ip bgp).

14. Verify that AS11's prefixes have been propagated to AS22 and AS33. (show ip bgp).

15. Advertise AS22's prefixes to its peers in the AS11 and AS33. AS22's prefixes are subnets of Loopback 0 interface of the router ISP2. Use the network statement for each individual subnet.

16. Verify that the router ISP1 has placed its connected routes into its BGP table. (show ip bgp).

17. Verify that AS22's prefixes have been propagated to AS11 and AS33. (show ip bgp).

18. In order to reach AS11's and AS22's subnets from hosts off R2's loopback interface, it necessary to redistribute BGP routes into EIGRP 10 domain, this way R2 will learn routes that exist in other autonomous systems in the topology.

19. Lastly, verify connectivity from R2's loopback0 interface to any of the subnets of AS11 and AS22.


Configuration example:

Configuration:
ER1(config)# router eigrp 10
ER1(config-router)# eigrp router-id 1.1.1.1
ER1(config-router)# network 33.0.0.0 0.0.0.3
ER1(config-router)# exit
!
ER1(config)# router bgp 33
ER1(config-router)# neighbor 11.0.0.5 remote-as 11
ER1(config-router)# neighbor 22.0.0.1 remote-as 22
ER1(config-router)# network 33.0.1.0 mask 255.255.255.0
ER1(config-router)# network 33.0.2.0 mask 255.255.255.0
ER1(config-router)# network 33.0.3.0 mask 255.255.255.0
ER1(config-router)# exit
!
ER1(config)# router eigrp 10
ER1(config-router)# redistribute bgp 33 metric 100000 10 255 1 1500
ER1(config-router)#exit

Verify:
ER1# show ip bgp summary
ER1# show ip bgp
ER1# show ip route bgp
ER1# show ip eigrp topology
ER1# show run | section bgp
R2# ping 11.0.1.1 source lo0